[ Microsoft .NET Framework 3.5 júniusi technikai el?zetes ]

Microsoft .NET Framework 3.5 júniusi technikai el?zetes

  • 2007-07-03 09:35
A Microsoft elérhet?vé tette .NET-keretrendszere 3.5-ös verziójának technikai el?ztes kiadását (CTP), melyet bárki szabadon kipróbálhat. Az új kiadás a 2.0 és 3.0 változatokkal teljesen kompatibilis, így a korábban megírt alkalmazások gond nélkül futnak tovább, de a 3.0 képességeit néhány új funkcióval b?víti ki.

A Windows Workflow Foundation (WF), Windows Communication Foundation (WCF), Windows Presentation Foundation (WPF) és Windows CardSpace komponensek mind új lehet?ségekkel gazdagodtak. A .NET-keretrendszer 3.5 f?bb újdonságai a következ?k:

  • A Language Integrated Query (LINQ) integrációja, és az adatok automatikus érvényesítése - a LINQ-vel kompatibilis nyelveken írt programok képesek saját nyelvükön lekérdezni, sz?rni és új objektumokat létrehozni SQL adatbázisokban, XML forrásokban és DataSet adatforrásokban

  • ASP.NET AJAX - interaktív, testre szabható és platformfüggetlen webalkalmazások készítése

  • WCF szolgáltatások készítéséhez szükséges új webes nyelves protokoll - AJAX, JSON, REST, POX, RSS, ATOM, és számos további WS-* szabványhoz

  • WF, WCF, és WPF alkalmazásokhoz szükséges teljes eszközkészlet

  • Új osztályok a felhasználói igények kielégítéséhez


2008-03-22 18:02
Nem gagyi az, csak a csík nem pontos. Egyébként miért jobb neked "közvetlenül"? Akkor nem kell letölteni? Így legalább mindig a legfrissebb komponenseket tölti le.

Windows telepít?

2008-03-22 17:57
Kibaszot lassan jön le!!! Gagyi letöltöje.
600 belekezd ujra. miért nem lehet közvetlenül?????
Jó napot kívánok , válasz a vista hum prémiumra total commander javasolt, a legújabb 7-es verzió.
ÜDV.

2007-07-18 12:12
JÓ NAPOT KIVÁNOK ,KÉRDÉS A VISTA HUM PRÉMIUMRA MILYEN ,COMMANDER JAVASOLT.
?DV .
Nem tudjátok véletlenül, hogy belekerül már a pop3/imap/exchange is? vagy még mindig csak smtp küldés lesz?
Jó ez meg minden, de valaki nem tudna olyan linket adni ahonnan a full 3.5-ös verzió letölthet? és nem csak az online telepítési fájl?

2007-07-03 12:41
a .net fw egyik vívmánya -ha úgy tetszik- az, h nem kell foglakozni a verziókövetéssel. nincsenek kompatibilitási gondok. ezért kell minden verziónak külön települnie.
vs2k8-ban meg szerencsére bevezették a verzió választót, szal az új vs-ben lehet 2.0, 3.0 és 3.5 is programozni (1.1nek teljesen más a debug módszere, csak gond lett volna vele).

moonman: [részben off] írhatnál egy olyan jófajta ismertet?t a cardspace-r?l. sztem érdekes téma és sokan keverik/nem látják a lényegét.
Az 1.1-es mindenképpen kell, mert a régebbi alkalmazások és a játékok (s?t vannak egyes mai alkalmazások is) ezt használják, enélkül nem is fut.
Hát nekem pl az Encarta 2006-hoz kell az 1.1-es, anélkül el se indul.....
Ezzel mondjuk csinálhatna vmit a ms (azon kívül, hogy vegyem meg a 2007-et :P)
Ertem, koszonom!

2007-07-03 10:25
Az 1.1-et nem kell, szinte már senki sem használja, elavult. A 2.0 nem az 1.1 frissítése volt, hanem egy külön verzió, egymás mellett futottak. A 3.0 pedig a 2.0 kiegészítése a Vista-technológiákkal, így ahhoz szükség van a 2.0-ra is.
moonman, nem tudod, hogy miert nem eleg csak feltenni mondjuk a 3.0-at, miert kell 1.x, 2.x, stb? Tehat a 3.0 miert nem tartalmazza az elozoeket is?